WordPress og indlejret Youtube

For et par dage siden skrev jeg indlægget “Kø-forklaring“, hvor jeg for første gang forsøgte mig med en indlejret Youtube-video. Det skulle jeg hurtigt komme til at fortryde :???:. Den kode, som Youtube angiver til indlejering, er nemlig ikke valid html. Udover at at ødelægge html-valideringen, ødelagde den også formateringen på den efterfølgende del af siden. Helt klart en uholdbar situation.

WordPress er ikke altid lige god til at håndtere “håndtilrettet” html-kode og selvom jeg fandt flere bud på, hvordan jeg kunne løse problemet, så dukkede det hele tiden op igen – WPs editor har nemlig en kedelig tendens til at håndtilrettet kode om til tekst, så for eksempel </a> bliver til &amp;lt;/a&amp;gt;.

Løsningen blev et af de utallige WP-plugins, nemlig WP YouTube. Det virkede nu heller ikke i første forsøg, primært fordi jeg ikke kunne finde det options-panel på det angivne sted og derfor antog at plugin’et ikke blev aktiveret korrekt. I følge vejledning skulle det være under “Indstillinger”, men da jeg tilfældigt fandt det, var det under “Håndter”. Så kom det dog også til at virke 🙂 .

Man kan have flere indlejrings-profiler og derfor skal man minimum oprette én. Det er altså muligt at have forskellige rammer, farver, etc. på sine Youtube-indlejringen og altsammen styret ved, at hver profil anvender sit eget tag – f. eks. [yt_med_ramme], [yt_simpel], osv. Indlejringen sker ved, at man angiver sit start-tag, efterfulgt af videons ID og afsluttet med slut-tag – [yt_simpel]Iurysg356[/yt_simpel]. Så bliver det ikke meget lettere :mrgreen:.

2 thoughts on “WordPress og indlejret Youtube”

  1. jeg forstår ikke problemet, men det afhænger måske af, hvilken version WP man kører. Jeg kan fint sætte koden ind og sætte ind, og har gjort flittigt brug af det, uden plugin!

  2. Hej Deborah

    Prøv at gå ind på din egen blog og tryk på linket “Gyldig XHTML”, som står nede under “Meta”, lige under “log ind”. Når jeg gør det, så får jeg “Result: Failed validation, 139 Errors”. Så det er så som så, med den gyldige xhtml på din side. Der er lidt forskellige småfejl, men det går helt galt nede i linje 309 (som din side ser ud i dette øjeblik), hvilket falder sammen med den første forekomst af en indlejret YouTube-video.

    Når jeg får problemer med resten af mit lay-out, mens du ikke gør, skyldes nok det tema vi hver især bruger. Dit tema overlever, mit gør ikke. Men faktum er, at begge teamer overlever i fin stil, når blot videoen indlejres i gyldig html-form – og det klarer plug-in’et. Husk også på, at din side måske ser ok ud i Internet Explorer og Firefox, men hvad med Opera, Konqueror eller MacIntosh’s Safari-browser? Alle understøtter korrekt visning af gyldig xhtml, men altså ikke nødvendigvis af din side, som den er nu.

Skriv et svar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *